Our engineers have implemented a fix that has addressed the inbound/outbound call issues that were reported, and we are now monitoring for continued stability.
We will provide a final update shortly.
Posted Jul 02, 2026 - 16:36 UTC
Update
Our engineers are continuing to investigate several underlying causes that result in the known issue. This includes identifying and following patterns, as well as understanding the full customer impact is. At this time, the investigation is ongoing.
We will provide additional updates shortly.
Posted Jul 02, 2026 - 16:06 UTC
Update
Our engineers are continuing to implement a fix for the issue.
We will provide another update shortly.
Posted Jul 02, 2026 - 15:14 UTC
Update
Our engineers are currently working on a plan to mitigate the issues and continue working toward resolution.
We will provide another update shortly.
Posted Jul 02, 2026 - 14:12 UTC
Update
Our engineers continue to investigate the issue and are actively working to determine the best path toward resolution.
We will provide another update shortly.
Posted Jul 02, 2026 - 13:43 UTC
Identified
Our engineers have identified the issue and are now actively working toward a resolution.
We will provide another update shortly.
Posted Jul 02, 2026 - 11:54 UTC
Investigating
We are actively investigating reports that a subset of GoTo Connect customers may be experiencing issues with inbound and outbound calls.
Our engineers are working to identify the issue and will provide another update shortly.