GoTo Connect - Contact Center and Call Reports Issue

Incident Report for GoTo Status Page

Resolved

We have confirmed that the issue has been resolved and that all systems are 100% operational.

We will conduct an internal review of this issue and make appropriate improvements to our system to help prevent or minimize future recurrence.
Posted Jun 19, 2026 - 13:11 UTC

Monitoring

Our engineers have corrected the issue and we are confirming that all services are functional.

We will continue monitoring the situation and provide a final update shortly.
Posted Jun 19, 2026 - 12:39 UTC

Update

Our engineers continue to investigate the issue. We will provide another update as soon as it is available.
Posted Jun 19, 2026 - 10:08 UTC

Identified

Our engineers have identified the issue and are now actively working towards a resolution.

We will provide another update shortly.
Posted Jun 19, 2026 - 08:38 UTC

Investigating

We are actively investigating reports of an impact affecting GoTo Connect, including Call History, Virtual Receptionist Reporting, Voicemail Deletion, and Call-Report Ingestion.

Our engineers are working to identify the issue and will provide another update shortly.
Posted Jun 19, 2026 - 08:33 UTC
This incident affected: Contact Center (Business Communication) (Contact Center).