GoToConnect and GoToMyPC - Service issues
Incident Report for GoTo Status Page
Resolved
We have confirmed that the issue has been resolved and that all systems are 100% operational.

We will conduct an internal review of this issue and make appropriate improvements to our system to help prevent or minimize future recurrence.
Posted Dec 16, 2024 - 22:18 UTC
Monitoring
Our engineers have corrected the issue and we are confirming that all services are functional.

We will continue monitoring the situation and provide a final update shortly.
Posted Dec 16, 2024 - 22:11 UTC
Update
We are seeing complete recovery for GoToConnect services. There are still some lingering issues with GoToMyPC and the team is still addressing these.
Posted Dec 16, 2024 - 21:53 UTC
Update
Our engineers are continuing to try to mitigate the issue and are seeing improvement for GoTo Connect services.

Some GoToMyPC customers are still experiencing issues accessing the product at this time.

We will provide another update shortly.
Posted Dec 16, 2024 - 21:21 UTC
Identified
Our engineers have identified an issue with a cloud provider, which impacts GoTo Connect as well as GoToMyPC. The team is currently working on mitigating impacts.
Posted Dec 16, 2024 - 20:30 UTC
Investigating
We are actively investigating reports that some GoTo Connect customers may be experiencing issues with their services, including Contact Center.

Our engineers are working to identify the issue and will provide another update shortly.
Posted Dec 16, 2024 - 20:15 UTC
This incident affected: GoTo Connect (Business Communication) (VoIP Calls - Deskphones, VoIP Calls - GoTo Connect Web, VoIP Calls - GoTo Connect Mobile, PSTN Calls - Inbound, PSTN Calls - Outbound).