GoTo Connect - Issue establishing calls

Incident Report for GoTo Status Page

Resolved

We have confirmed that the issue has been resolved and that all systems are 100% operational.

We will conduct an internal review of this issue and make appropriate improvements to our system to help prevent or minimize future recurrence.
Posted Mar 28, 2025 - 15:28 UTC

Monitoring

Our engineers have corrected the issue and we are monitoring the improvement in establishing calls.

We will continue monitoring the situation and provide a final update shortly.
Posted Mar 28, 2025 - 15:12 UTC

Update

Our engineers are investigating possible actions to mitigate the impacts of the current problem and are receiving reports that the situation is improving.

We will provide another update shortly.
Posted Mar 28, 2025 - 15:04 UTC

Identified

Our engineers have identified the issue and are now actively working towards a resolution.

We will provide another update shortly.
Posted Mar 28, 2025 - 14:45 UTC

Investigating

We are actively investigating reports that some GoTo Connect customers may be experiencing issues making or receiving calls.

Our engineers are working to identify the issue and will provide another update shortly.
Posted Mar 28, 2025 - 14:29 UTC
This incident affected: GoTo Connect (Business Communication) (VoIP Calls - Deskphones, VoIP Calls - GoTo Connect Web, VoIP Calls - GoTo Connect Mobile, PSTN Calls - Inbound, PSTN Calls - Outbound).