GoTo Webinar, GoTo Training and GoTo Meeting- Issue starting sessions

Incident Report for GoTo Status Page

Monitoring

Our engineers have corrected the issue and we are monitoring recovery across all services which were affected.

We will continue monitoring the situation and provide a final update shortly.
Posted Mar 18, 2026 - 16:04 UTC

Update

We are seeing improvements in GoTo Webinar, Training and Meeting as mitigating actions are being deployed.

We will provide another update shortly.
Posted Mar 18, 2026 - 15:58 UTC

Identified

Our engineers have identified the issue and are now actively working towards a resolution.

We will provide another update shortly.
Posted Mar 18, 2026 - 15:51 UTC

Investigating

We are actively investigating reports that some GoTo Webinar customers may be experiencing an issue starting sessions.

Our engineers are working to identify the issue and will provide another update shortly.
Posted Mar 18, 2026 - 15:37 UTC
This incident affects: GoTo Meeting, GoTo Webinar, and Collaboration Tools (GoTo Meeting, GoTo Webinar, GoTo Training).