GoTo Meeting, GoTo Webinar, GoTo Training, GoTo Stage, OpenVoice and GoTo APIs - Maintenance

Scheduled for Nov 9, 05:00 - 07:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 19, 2025 - 19:56 UTC

Scheduled

As part of our commitment to providing exceptional service and reliability to our customers, GoTo Meeting, GoTo Webinar, GoTo Training, GoTo Stage, OpenVoice and GoTo APIs will conduct service maintenance on the following date and time, as listed below. Our team will take all necessary actions to minimize service interruptions during this event.

The maintenance will occur on the date and time listed below.

Date and Time: November 9th, 2025 at 05:00 AM to 07:00 AM UTC.

Purpose: This maintenance is to ensure and maintain system performance and stability.

Duration: All maintenance will be performed within the 2-hour maintenance window.

What to expect: During the switchback, GoToMeeting, GoToWebinar, GoToTraining, GoTo APIs, GoToStage, and OpenVoice products will not be available.

We would like to thank you for your patience and understanding during this time.
Posted Sep 19, 2025 - 06:45 UTC
This scheduled maintenance affects: GoTo Meeting, GoTo Webinar, and Collaboration Tools (GoTo Meeting, GoTo Webinar, GoTo Training, OpenVoice, GoTo Stage) and GoTo API (GoTo Meeting API, GoTo Training API, GoTo Webinar API, GoTo Connect API).