Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 13, 2025 - 09:00 UTC
Scheduled
As part of our commitment to providing exceptional service and reliability for our customers, GoTo will be conducting service maintenance with Rescue on the following date and time listed below. As always, our teams will take all the appropriate actions to minimize service interruptions during these events.
Date and Time: Monday October 13th, 2025, between 09:00 AM to 10:00 AM UTC
Purpose: The certificate we use to sign SAML 2.0 authentication requests initiated from LogMeIn Rescue login page is about to expire on October 29th, 2025. Therefore, we will be renewing the certificate on October 13th.
Duration: All maintenance will be performed within the 1-hour maintenance window.
What to expect: To ensure uninterrupted service, we kindly request that you update the SAML certificate stored on your end to the new one before the specified maintenance window.
If your security policy requires that certain certificates issued by external service providers (such as LogMeIn Rescue) should be explicitly trusted in advance, you might need to add this certificate to your company’s Trusted Certificate Store before we start using the new one for digital signing.
1. If the technicians in your company are NOT using the SP-initiated login method:
then you may need to re-import this metadata into your Identity Provider after we complete the renewal.
How do I know if I am impacted?
Both conditions must be met for your account to get account.
1) If the account signs into SSO via SP (software provider) by going directly to secure.logmeinrescue.* AND 2) The company's Identity Provider / IT Admin configured SSO using Rescue metadata (downloaded at one of the mentioned URLs above)
There is not a way for anyone at GoTo to know if Rescue metadata was used in previous configurations.
The Rescue SAML certificate renews each year.
The certificate in the Rescue Admin Center> Global Settings is the metadata from the company's Identity Provider, not Rescue, and is a different certificate.
If you are not sure if you are affected, the best practice will be to reach out to your Identity Admin or whomever set up your SSO configuration to ask if Rescue metadata was imported into your Identity Provider.
If that answer is "No" then no action is needed.
If that answer is "Yes" then action is needed.
If the answer is "Yes" and they need the certificate before it expires, please contact our Support team.
If you have any further questions regarding this event, please feel free to contact the GoTo Team.
We would like to thank you for your patience and understanding during this time period.
Posted Sep 16, 2025 - 11:03 UTC
This scheduled maintenance affected: Rescue and GoToAssist (Remote Support) (Rescue).