We have confirmed that the issue has been resolved and that all systems are 100% operational.
We will conduct an internal review of this issue and make appropriate improvements to our system to help prevent or minimize future recurrence.
Posted May 14, 2026 - 02:22 UTC
Monitoring
Our engineers have corrected the issue and we are confirming that all services are functional.
We will continue monitoring the situation and provide a final update shortly.
Posted May 14, 2026 - 02:12 UTC
Update
Our engineers are executing on the established plan to get back the system to prolonged stability
We will provide another update shortly.
Posted May 14, 2026 - 02:03 UTC
Update
Our engineers have identified a plan to get back the system to stustained stability and are starting to execute on it.
We will provide another update shortly.
Posted May 14, 2026 - 01:12 UTC
Update
We are continuing to work towards a resolution to ensure stability in starting and joining sessions.
We will provide another update shortly.
Posted May 14, 2026 - 00:37 UTC
Identified
Our engineers are still seeing some intermittent issues after the fix and are continuing to investigate those. We will provide a status update once we have further information.
We will provide another update shortly.
Posted May 13, 2026 - 22:40 UTC
Monitoring
A potential fix was applied to resolve the issue, and we are continuing to monitor for stability.
We will continue monitoring the situation and provide a final update shortly.
Posted May 13, 2026 - 22:28 UTC
Update
Our engineers are continuing to work on isolating the source of this issue. Due to its intermittent nature, trying again can allow to establish a proper connection.
We will provide another update shortly.
Posted May 13, 2026 - 21:13 UTC
Update
Our engineers are continuing to work on this issue and continue to work towards a resolution.
We will provide another update shortly.
Posted May 13, 2026 - 20:04 UTC
Identified
Our engineers have identified the issue and are now actively working towards a resolution.
We will provide another update shortly.
Posted May 13, 2026 - 19:22 UTC
Investigating
We are actively investigating reports that some LogMeIn Rescue and Central customers may be experiencing issues downloading the applet to start or join remote sessions.
Our engineers are working to identify the issue and will provide another update shortly.
Posted May 13, 2026 - 18:58 UTC
This incident affected: Rescue and GoToAssist (Remote Support) (Rescue) and GoToMyPC, Pro, Central, and Hamachi (Remote Access) (Pro/Central).